Fallos en varios Plugins con la nueva versión de Windows 10



Jose R. Pavía

Hola David.

Me he encontrado con un problema. Ninguno de estos plugins funcionan correctamente en la nueva versión de Windows 10.
npBars, npCams, npConf, npDrop, npFile, npFind, npGrid, npList, npLogs, npNots, npPdfs, npQrco, npStrs, npTalk, npXmls y npZips.

Si funcionan en programas ya compilados, es decir, en el EXE. También funcionan si escribo los comandos manualmente, pero no al intentar seleccionarlos y que me aparezcan las ventanas correspondientes para insertar los datos de cada comando, además, bloquean y cierran VisualNeo.

Me aparece un mensaje indicando que el Plugin está mal instalado, que lo vuelva a instalar. Una vez hecho, el problema persiste.

Sólo me pasa con la versión Aniversary update.

¿Alguna idea? Saludos.


David Esperalta

Hola José,

Hace un par de "releases" atrás se descubrió un "bug" introducido al cambiar yo de un entorno de 32 bits a otro de 64 bits. No obstante dicho error se solucionó, y, ciertamente, no he recibido otro reporte de problema alguno.

No estoy seguro de si tengo la versión de Windows 10 "Aniversary", pero sí que trabajo y los plugins se compilan en Windows 10. Tengo que mirar a ver cómo actualizar a Windows 10 "Aniversary" si es que esto fuese posible.

Por otro lado, ¿puedes referir el error aquí textualmente? Esto ayudaría mucho.

Y dicho lo anterior, por favor, desinstala todos los plugins, borra manualmente (después) las claves del registro siguientes:

Después de eso, por favor, descarga las versiones actualmente disponibles de los plugins y prueba a instalarlos de nuevo. Si el error persiste no dudes en comunicarlo aquí y trataré de ayudarte a la mayor brevedad posible.

¡Siento las posibles molestias! :(


Consider to purchase one or more licenses of our products: press here!

Jose R. Pavía

Ok, no sabía nada de el bug ese.

En cuanto al error... dice lo siguiente:
The "npBars" plugin installation is corrupted. Please, install this plugin again.

Me cuadra con el cambio de claves en el registro.

De todas formas, haré limpieza de plugins, limpieza de registro y volveré a instalar los plugins que tengo. Si descargo las últimas versiones ¿me siguen funcionando mis licencias?

Saludos y gracias por responder tan rápìdo.


David Esperalta

Hola José,

En efecto, dicho "error" es un mensaje que lanzan los propios plugins, es decir, afortunadamente, puede solucionarse haciendo limpieza del registro de Windows (tanto de las claves "David Esperalta/NeoPlugins", como de las claves "NeoSoft/Plugins" y "NeoSoft/PluginsData") y la reinstalación correspondiente.

Por otro lado, las licencias "no expiradas" funcionarán sin problemas con las nuevas versiones. Para las licencias "expiradas" deberás usar antiguas versiones de los plugins, si es que no vas a actualizar las licencias ahora mismo José. Puedes encontrar [s]las versiones antiguas aquí en Dropbox[/s]. Ya están disponibles en el área de cliente de DecSoft. :)

Por supuesto, si encuentras cualquier otro problema, no dejes de publicarlo en este foro o contactar conmigo José.

P.D. Un consejo cuando hemos de registrar varios plugins... no los registres todos a un tiempo, sino, según los vayas precisando en los proyectos que los uses. De este modo la tarea de registrar "tantos" plugins se reduce considerablemente.


Consider to purchase one or more licenses of our products: press here!

Jose R. Pavía
P.D. Un consejo cuando hemos de registrar varios plugins... no los registres todos a un tiempo, sino, según los vayas precisando en los proyectos que los uses. De este modo la tarea de registrar "tantos" plugins se reduce considerablemente.

No sabes lo buen consejo que es lo que acabas de decirme, jajajaja... me paso "horas" registrando uno por uno. Gracias por la idea.

Copiado lo de las licencias "expiradas".


David Esperalta

Hola José,

P.D. Un consejo cuando hemos de registrar varios plugins... no los registres todos a un tiempo, sino, según los vayas precisando en los proyectos que los uses. De este modo la tarea de registrar "tantos" plugins se reduce considerablemente.

No sabes lo buen consejo que es lo que acabas de decirme, jajajaja... me paso "horas" registrando uno por uno. Gracias por la idea.

Copiado lo de las licencias "expiradas".

Sí; en realidad VisualNeo no permite registrar más de un plugin a la vez, cosa que, por otro lado, igual es comprensible, porque, habría que "inventar" algún modo. Pero, es cierto que (probablemente) no usamos todos los plugins es un mismo proyecto, de modo que no hay necesidad de registrarlos todos... que puede convertirse en un trabajo "pesado", o sea, los peores...

Respecto de la posible actualización de las licencias, recuerda que esto no se hace desde la tienda de DecSoft "regular", sino desde el apartado de clientes de DecSoft. Ahí podrás actualizar el número de licencias que precises, siempre al mejor precio. Quisiera mejorar este apartado también añadiendo enlaces a las antiguas versiones para que quede claro que también estas están disponibles y sea más cómodo acceder a las mismas.


Consider to purchase one or more licenses of our products: press here!

Jose R. Pavía

Bueno, parece que el problema está solucionado.
He probado con varios de los plugins que fallaban y ahora van bien.
Ya los iré registrando a medida que los vaya utilizando, jejeje...

El tema me corría prisa porque varios de los plugins que estoy usando en un proyecto (de encargo) me estaban fallando, así que te puedes imaginar, jejeje...

Lo dicho, problema solucionado.
Te debo una birrita.


David Esperalta

Hola José,

Me alegro de que todo fuese bien. Y gracias por la cervecilla, hombre, je je je. :)


Consider to purchase one or more licenses of our products: press here!

David Esperalta

Hola José,

Pues nada, que, como comenté más arriba que iba a hacer, he preparado una nueva "pestaña" en el área de clientes de DecSoft, desde donde es posible descargar cualquier versión expirada o caducada de NeoPlugins y también de otros programas. Echa un vistazo cuando quieras José, desde ahí tendrás acceso siempre a dichas versiones. :)


Consider to purchase one or more licenses of our products: press here!

Jose R. Pavía

Hola de nuevo David.

He vuelto a tener problemas con otros 3 plugins, los tres que puedo actualizar (npCiph, npSapi y npUtil).

Al instalar las actualizaciones ha perdido el registro y al intentar meter los datos no los acepta... simplemente no se registran.

He hecho los mismos pasos que la vez anterior desinstalándolos y eliminando las claves de registro, pero nada, que la cosa no marcha...

También he intentado hacer lo mismo y luego instalar las versiones anteriores... tampoco me deja registrarlas ahora...

Alguna idea?


David Esperalta

Hola Jose,

Hace hace poco me reportaron ciertos problemas con las licencias: no recuerdo que los plugins que mencionas estuvieran entre los afectados, pero, puesto que acabo de probar a registrar npUtil con tus datos y todo va bien, por favor, te ruego que descargues las últimas versiones de los plugins, sólo para estar seguros de que estamos trabajando con las mismas versiones.

P.D. Parece que el asunto tiene que ver con que no has recibido las nuevas licencias: las encontrarás en el área de cliente de DecSoft Jose.


Consider to purchase one or more licenses of our products: press here!

Jose R. Pavía

Problema resuelto, gracias de nuevo David... Como siempre solucionando problemas raudo y veloz.

Gracias!!!


David Esperalta

Hola,

Problema resuelto, gracias de nuevo David... Como siempre solucionando problemas raudo y veloz.

Gracias!!!

¡Siempre gracias a ti Jose! :)


Consider to purchase one or more licenses of our products: press here!

Everybody can read the DecSoft's support forum for learning purposes, however only DecSoft's customers can post new threads. Purchase one or more licenses of some DecSoft's products in order to give this and other benefits.